Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 26, 2026 - 16:00 PDT
Scheduled
Start Time: June 26, 2026 – 7:00 PM ET Estimated Duration: Up to 12 hours
Affected Environments: Selected stacks only
We will be deploying CRPM 26R1 release to selected stacks. This rollout introduces major enhancements focused on improving data workflows, automation, platform connectivity, and overall security posture.
During this maintenance window, impacted stacks will be unavailable. Normal access will resume once the rollout is complete.
Posted Jun 25, 2026 - 22:23 PDT
This scheduled maintenance affected: Login & User Authentication, Web Application Service, Financial Modeling Service, Analytics, Document Management, Collaboration Services, E-mail Notifications, API, Support Portal, Tasks, My Tasks Widget, Box Desktop Client, Box Content API, Box Content Preview, Box Search, Box Webhooks, Box Uploads/Downloads, Box Authentication (OAuth 2.0 / JWT), Box Web Application, AWS ec2-eu-central-1, AWS ec2-us-west-2, AWS elb-eu-central-1, AWS elb-us-west-2, SendGrid SMTP, Mercatus Excel Plug-in, and Integration.